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2023.00-09   [268919] 2023-10-18

  Fixed Bugs

File import / export
Synchro import: When a file contained an invalid row identifier, Vistro would show many error messages. Now it is
possible to suppress further error messages. (198714)
Vissim: An issue was fixed, where detectors in some cases were not connected properly to call and extend signal
groups. The signal groups therefore were not called and remained red. (180056)

Signal timing optimization
Undo: Undo did not work correctly after optimization. The splits were not set to the correct values before the
optimization. This issue was fixed. (197228)

Trip Distribution tab
Many zones: Vistro sometimes crashed, when the trip distribution tab was opened in a network with more than 150
zones. This issue was fixed. (194108)

Trip Generation
ITE Trip Gen: When the 'Fitted Curve' setting is used in the dialog ITE TripGen, Vistro now also transmits the values
Quantity, %In, and %Out to the zone. This way the values are consistent. (198808)
Report 'Trip generation summary': The reporting for zones with data entry type 'Trips' was changed. The value trip
generation rate no longer is reported. Quantity, %In, and %Out are reported but grayed out. (198820)
 

2023.00-08   [265886] 2023-08-25

  New Features and Changes

Installation
Update CodeMeter Runtime: The CodeMeter Runtime deployed with PTV Vistro has been updated to CodeMeter
7.60c. (189716)

  Fixed Bugs

Graphical editors
Inserting routes: When a route is being inserted, Vistro now again allows adding intermediate points on
intersections. This is the same functionality as when a path is being inserted. (161170 | 2294)

Network optimization

 (189015 )

Traffic control tab

Show all signalized intersections: Due to an error it was possible that not all signalized intersections where shown
on routes in the network optimization tab. This error was fixed. This error only occurs, when parts of the network
were created using Synchro import. This could happen either if the network was originally imported from Synchro, or
if parts of the network were created using the merge feature.



Missing patterns: An issue was fixed, where patterns with numbers 2-8 were missing in scenarios. This happened
when a pattern with number 2-8 was added to a scenario, and the base scenario of the Vistro file still had an old
format, i.e. it was not yet saved with Vistro 2023, Service Pack (SP) 5 or higher. The new patterns were missing
when the scenario was closed and reopened, or the Vistro file was closed and reopened. The issue only affected
Vistro 2023, SP 5 and higher (184055)

  Breaking Changes

Network optimization

(189015 )
 

2023.00-07   [262232] 2023-07-03

  New Features and Changes

Simulation
Vissim preview updated: The Vissim preview has been updated to version PTV Vissim 2023.00-08. (180879)

  Fixed Bugs

Traffic Control tab
Patterns: When a pattern was added in a scenario, the data for the signal groups of that pattern was not stored
correctly and the data was lost, when the scenario was reopened. Patterns with number greater than 8 were only
saved in the base network, not in scenarios. When patterns with number greater than 8 were entered in a scenario,
they would be lost when the file was saved and reopened. All these issues were fixed. (182533)
 

2023.00-06   [260914] 2023-06-12

  New Features and Changes

Simulation
Vissim preview updated: The Vissim preview has been updated to version PTV Vissim 2023.00-06. (168846)

Traffic Control tab
Maximum Green: When the Split (or Amber, All red, or Delayed Vehicle Green) of a signal group is changed, Vistro
now adjusts Maximum Green automatically. Maximum Green then is equal to the split minus Amber, All red, and
Delayed Vehicle Green. The condition for the automatic adjustment is that Maximum Green was equal to Split minus
the other values before one of the other values was changed. When 'Create Default Signalization' is used, Maximum
Green will now be consistent with the splits. When a signal group is inserted by entering a number in the cell, the
Maximum Green of the new signal group will be equal to the split minus Amber, All red, and Delayed Vehicle Green.
(177969)

Trip Generation tab
Internal capture: A column '% Internal Capture' was added to the grid. It allows entering values between 0 and 100
and should be used to model demand that is captured in the zone. This demand is then subtracted in the following
calculations. New columns 'Trips Generated Adjusted', 'Trips In Adjusted', and 'Trips Out Adjusted' show how the
internal capture affects demand. The adjusted values are then used in the trip distribution and in the path volumes.
Internal capture and adjusted demand values are also shown in the report. (160845 | 919)

  Fixed Bugs

Calculation

 (178526 )

Results of the network optimization may change if parts of the network were created using Synchro import.

Other modes: An issue was fixed in the calculation of I_p, int, Pedestrian LOS Score. The calculation was incorrect,
when metric units were used.



 (174192 )

 turns in HCM 2010 and HCM 6. (178264 )
f_RT and f_LT: The values were sometimes shown as relevant, when they were not relevant, and vice versa. This
issue was fixed. The left-turn value f_LT, for example, is only relevant on left turns, and only if phasing is not
permissive. (177716)

File import / export
Centracs export: An issue was fixed, where the list of intersections contained too many intersections. (173175)
Import Merge Data: An issue was fixed, where the import of Merge Data did not work. This issue only occurred when
a .vistro file was opened by double-clicking in the Windows File Explorer. Specifically, the workflow (1) opening a
.vistro file from the File Explorer, (2) switch to Base Scenario, (3) open Merge Data did not work correctly. Now,
merge data will correctly be imported in the base network. (171486)
OSM import, Vissim export: An issue was fixed, where no data was exported to Vissim when a network previously
was imported from OSM data. The reason for this was that the 'Analyze intersection?' flag was always unchecked
after the OSM import. Now, the analyze flag is checked by default after an OSM import and all data will be exported
to Vissim. (170283)

Licensing
Dialog language: An issue was fixed, where the license dialog used the wrong language. It now uses the language
that was set the last time that Vistro was used. (172279)

  Breaking Changes

Calculation

 (178526 )

 (174192 )

 (178264 )
 

2023.00-05   [257836] 2023-04-13

  New Features and Changes

File import / export
Centracs: File menu File -> Export contains a new entry 'Centracs' which exports timing data (splits, cycle lengths,
and offsets) to Econolite Centracs. It is possible to determine, for which intersections data should be exported, and
if all patterns or only the active pattern should be exported. One file for each intersection will be placed in a
selectable destination folder. File names will contain the names of the intersection for easier identification. (165411)
Order of entries: The order of other menu entries was changed. A new entry 'Centracs' was added to the File ->
Import menu. It allows import of timing and phasing data from Econolite Centracs. (171001)

Traffic Control tab

Signalized: An issue was fixed in the volume distribution to shared lanes. The volume distribution was incorrect,
when there was a left movement with low volume, a shared left-through lane and at least one other lane associated
with the through movement. In this case, too much volume was put on the left-through lane and too little volume was
put on the other through lanes. There was a symmetrical issue with shared through-right lanes.
Signalized: The factor f_s  = 0.91 (see Equation 31-65, HCM 2010) was not applied consistently in all cases. This
issue was fixed. It is only supposed to be applied, when the left turn is permissive. This is clearly stated in HCM 7th
Ed. (see text after Equation 31-62, HCM 7th Ed.). The fix is also applied to HCM 2010 and HCM 6th. Ed, because
from other locations (text after Equations 31-105 and 31-107, HCM 2010), it is likely that f_s should also be
restricted to approaches with permissive left

Other modes: The value I_p, int, Pedestrian LOS Score may change if metric units are used.
Signalized: Calculation results will (strongly) deviate from earlier versions, if there is a left lane, a shared-left lane
and at least one other lane with through movement, and in the symmetrical case with a right lane, a shared right-
through and at least one additional through lane. Volume distribution will be different, resulting in different delays,
queues, and level-of-service, among other values.
Signalized: Calculation results on signalized intersections will be different on approaches with left turns, if the is a
shared left-through lane and at least one additional through or through-right lane.



Patterns: Vistro now supports multiple signalization patterns in a single signal controller. A pattern contains several
values for each signal group, most prominently the split. When a pattern is set to active using the new 'Active
Pattern' control in the Intersection Settings sub-table, splits are adjusted and calculations are now based on the
newly activated pattern. All other patterns remain in the background and they will be exported to Vissim. The set of
patterns on a controller can be managed by using the new 'Patterns' button on the toolbar of the Traffic Control tab.
The button opens the new 'Patterns' dialog, where patterns can be added, updated, and removed. The value
'Coordination Type' now only can be set to Time of Day Pattern Coordinated and Isolated. The entry 'Free Running'
was removed. It can now be set in the Active Pattern control. When UTDF Timing Plans files are imported, the timing
plans will show up as selectable patterns in the Active Pattern control and in the Patterns dialog. (165410)

  Fixed Bugs

File import / export
Centracs, UTDF: Cycle lengths are no longer adjusted automatically to accommodate late pedestrian phases, that
exceed the cycle length. As a consequence, cycle lengths will have the value as it is in the imported file. (171244)
UTDF import: Intersections are no longer switched from fully actuated to semi-actuated. This happened in earlier
versions on intersections with signal groups that were marked as 'coordinated'. (167981)
UTDF import: There was an issue, where lane widths were changed when a UTDF import was executed. This issue
was fixed: Lane widths will no longer change. (161175 | 2299)

Traffic Control tab
Exclusive Pedestrian Phase: Vistro no longer crashes, when Pedestrian Walk or Pedestrian Clearance are set,
while Pedestrian Signal Group is 0. (169534)
 

2023.00-04   [255036] 2023-02-07

  Fixed Bugs

Calculation

 (161165 | 2292 )

Reporting
Copyright information: The copyright information at the bottom of graphical reports is now smaller. (161154 | 2280)
Protected, Permissive: An issue was fixed, where values of the Control Types Protected and ProtPerm could not be
distinguished, because the cells were too small. The width of the caption column in the report depends - as before -
on the width of the caption columns in the grids on the screen. However, after the fix the width of the columns in the
report is now much closer to the ones of the grids. (161163 | 2290)

  Breaking Changes

Calculation

 (161165 | 2292 )
 

2023.00-03   [254299] 2023-01-20

  New Features and Changes

Simulation & ANM
Previewer: The Vissim previewer was updated to a new version. (161147 | 2267)

Signalized, approach delay: Unsignalized movements were not taken into account correctly in the calculation of
approach delay, when the movement's delay was set to 0. Such movements were ignored completely in the
approach delay. This issue was fixed. The movement's volume now is taken into account in the denominator of the
equation.

Signalized: Approach delay will be different, if there is an unsignalized movement with delay set to 0 and non-zero
volume.



  Fixed Bugs

Graphical editors
Object with key already exists: An issue was fixed, where two successive error messages appeared when trying to
insert an intersection. The error messages were 'An object with the key ... already exists in the network'. and 'Newly
created node does not have an east-, west-, north- or southbound leg.' (161161 | 2288)

Scenario management
Fixed crash when switching scenarios: A second issue was fixed. This also only occurred when the network
optimization tab was open when the scenario was switched. (161156 | 2283)
 

2023.00-02   [253135] 2022-12-15

  Fixed Bugs

File import / export
UTDF lanes: Pedestrian volumes are now imported correctly. (110875 | 2274)

Scenario management
Fixed crash when switching scenarios: An issue was fixed, where Vistro sometimes crashed when a scenario was
opened. This only happened in certain networks, and only when the Network Optimization tab was open, while the
scenario was opened. (110874 | 2273)
 

2023.00-01   [252538] 2022-12-02

  New Features and Changes

File import / export
Egnyte: An issue was fixed that prevented the Egnyte system from seamlessly working together with Vistro.
(110867 | 2257)
UTDF: The UTDF import was extended and improved. The menu entry File ->Import -> UTDF... now opens a dialog
that allows an extended file selection from a specified folder. Multiple files and UTDF types can be selected by
holding down the shift or control keys or by using the select all/none toggles and imported at the same time. An
intersection filter ('Import section') sets the import scope for the file selection set to single or all intersections or to
intersections in a coordination group. For Volume UTDFs a filter ('Volume import') sets the import scope for turn
movement counts by time and date. The import of UTDF lane group files now also takes into account the data rows
'Lanes', 'Shared', 'Storage', and 'StLanes' attributes. (110863 | 2247)

  Fixed Bugs
Synchro import: An issue was fixed regarding the actuation type of signal controllers. When a signal controller
contained pedestrian signal groups, fixed-time controllers where wrongly set to semi-actuated. (110872 | 2266)

Graphic parameters
Detailed traffic conditions: Vistro no longer crashes, when 'Show Detailed Traffic Conditions' is turned on and the
shown section of the network is changed. In earlier versions Vistro could crash while panning in the network. This
only happened when there where unused exit approaches. (161142 | 2256)

Simulation & ANM
Missing signal heads: An issue was fixed, where signal heads were missing in Vissim after an export. This only
happened in networks that were imported from Visum. (110866 | 2255)

Traffic control tab



Signal Coordination Group: After reading merge data, editing the cell 'Signal Coordination Group' did not work
correctly. When a low number was selected, the control automatically changed to a larger number. This issue was
fixed. (110864 | 2253)
 

2023.00-00   [249758] 2022-09-22

  New Features and Changes

File import / export
Synchro import: The description of intersections is now imported into Vistro's 'Notes' field, no longer into the
'Intersection' field. (110641 | 1941)
Synchro: Detector data from Synchro imports has been updated. Previously, on shared lanes, when the right turn
was permissive, and through and right movements had different detector data in the Synchro file, the data of the
right turn was used. Now, the data of the through movement is used. (110859 | 2238)
UTDF import: Vistro now supports the import of several UTDF file types: Lane Group Data, Phasing, Timing Plans,
and Volumes. These imports are accessible through the File -> Import -> UTDF... menu entry. This feature is
experimental and requires extensive user testing to comply with different formatting from data providers and
conditions. User feedback is appreciated. The Lane Group Data UTDF currently focuses on volume parameters for
providers such as Miovision. Geometric parameters will be added in future service packs. Phasing and Timing
UTDFs have been developed for Econolite Centrac imports. An improved import dialog will be coming in a future
service pack to improve the import workflow and enable the import of multiple files at one time. For the combined
Synchro .csv import, please use the importer under File->Import -> Synchro... (110827 | 2202)

Optimization
 (110821 | 2197 )

Simulation & ANM
New RBC data format: The Vissim (ANM) export now uses the new RBC data format, i.e. it exports files with the
extension .prbc. These can be imported using the ANM import in PTV Vissim 2023. The export also issues warnings,
if there are controllers that do not run in Vissim due to data problems. It is not necessary to open Vissim for that.
The messages are written to the message file (View->Message File). (110770 | 2116)

Trip generation tab
ITE TripGen: All values entered in the dialog 'ITE TripGen', like Subcategory, Setting/Location etc. are now saved to
the Vistro file. The drop-down lists will be repopulated with all of these saved values when the dialog is opened the
next time, so calculations can quickly be conducted and data plots reviewed. (110808 | 2179)

  Breaking Changes

Optimization
 (110821 | 2197 )

Offset optimization: The results of the network optimization with offset optimization might differ from previous
versions. (110820 | 2196)

Hill Climbing: The offset of the master controller now remains unchanged.

Hill Climbing: The results of network optimization with Hill Climbing may differ.
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